?

Log in

No account? Create an account
Dec. 9th, 2014 @ 09:39 pm Alienware 14 screen troubles
(Facebook/LJ crosspost)
Well, this past month has been bloody annoying. The screen on my Alienware 14 laptop suddenly went all weird. It would flicker cyan and purple and the top of the display would end up on the bottom of the display as well. (Makes using the start bar an exercise in faith when you can't see it!) Shutting and opening the lid would more often than not just result in a black screen, but very occasionally would make the screen fix itself.

I dreaded the screen turning off, and any time I would have to restart the computer. I knew I would have a massive battle just to get the screen working again.

The problem being so intermittent made me wonder what the cause could be.

I've been looking online to find out what was going on, and kept on finding wildly different answers, many of which were quite expensive! But the solution seems a lot simpler than dodgy cables or dodgy LCD screens - the driver! NVidia's latest driver seems to be the problem. After rolling back to the previous driver, I was able to restart the computer without the screen going wonky.

Here's an example of the screen flickering:
https://www.youtube.com/watch?v=eaqRaqBqwog
About this Entry
[User Picture Icon]
From:lirazel
Date:December 9th, 2014 01:44 pm (UTC)
(Permanent Link)
Interesting! I had pure hell due to an Nvidia driver once, trying to play "Beyond Good and Evil." I finally gave up. One wonders about their QA.

Nice to read you again!
[User Picture Icon]
From:sscougall
Date:December 10th, 2014 08:15 pm (UTC)
(Permanent Link)
The other thing is that this dodgy driver came out somewhere around end October / beginning November, yet NVidia hasn't released a fix yet. So yes, you have to wonder what's happening with their QA?